View Full Version : Wilcom ES-2006 SP4 Revision 2 Working with Windows 7 32/64bit

02-18-2010, 02:22 AM
Ok it has taken me a little while to get the complete package working correctly, but all the bugs are now worked out of it
and it is in a complete package with everything you need SP4 revsion 2 and the new emulator.

Works on ALL Windows even Windows 7 64 bit.

I am posting now to alt.binaries.crafts.pictures
which is a embroidery newsgroup.

DO NOT PAY anyone for this solution, there it is FREE for ALL. ;)

02-18-2010, 05:11 AM
It sounds great :)
But I`m not very experienced, how can I download the package from there? :D I see 29 records but how to get them :confused:

02-18-2010, 07:30 AM
Litmanen - wrong place to ask that question. Use google.

Sgraphixs -

1) What is the DEFAULTS.DFL file in the Emultaor directory?. Is this emulator standard or altered in some special way?

2). Why install.cmd and install2.cmd?. They both do exactly the same thing, one echoes it to the console, the other doesn't.

3) Why do you install the emulator before you install thye Reg file?. If you install the Reg file first, then install the emulator, you do not need the reboot. You also so not need the reboot if you restart the emulator with restart.cmd which you have removed from the emulator files for some reason.


02-19-2010, 12:03 AM

did you test this emu ? or not ,,

not working with me , if any body test it , give results please

02-19-2010, 12:31 AM
[PLEASE STOP quoting whole messages. Why is this so difficult to understand?]

I do not see the archives that can test.

02-19-2010, 05:12 AM
I also doesnt see anything :)

02-19-2010, 07:59 AM
Then look where he told you he had posted it. It is on the alt.binaries.crafts.pictures Usenet newsgroup, complete with more than enough recovery files for somebody on the other end of a piece of wet string to download it successfully.


02-19-2010, 11:53 AM

yepp with the Revery Files you can complete the DL from there. At the moment i couldnt test this app by myself if the Reg File works. Will try it later this week.



02-19-2010, 12:09 PM
I got below noted from Wilcom AU:Users of 64-bit Operating Systems please note :
ES Version 9 and below have not been officially tested under 64-bit operating systems. ES 2006 (with Service Pack 4 Revision 2) and above will run on 64-bit operating systems such as Windows XP x64 and Windows Vista 64-bit as these operating systems can still run 32-bit applications natively. Note that some Windows Server x64 operating systems running on 64-bit CPUs are not able to run 32-bit applications like Wilcom ES 2006 without hardware emulation.

How did you get it work on x64?!


02-19-2010, 12:17 PM
[PLEASE STOP quoting whole messages. Why is this so difficult to understand?]

Like I know, people got the problem when use the PickUp function and getting trouble with Screen Calibration, you should copy that file into installed folder under /wilcom/es2006/res

Try it by yourself to see how it is because I've not had SP4 Rev.2 to test it correctly.

02-19-2010, 03:06 PM
asus - thank for that. I will try it for myself when the original poster has bothered top answer my questions, and when somebody tells me it has worked on their system. So far, I have only heard of failures.


02-19-2010, 10:07 PM

Yes, like you, I heard almost people get this stuff does not work properly at all, someone worked, but I do not know how they use it because after 10~30mins, software terminated automatically.

02-19-2010, 10:14 PM

just tested if it works.

First of all. Tookes ages to install. Then it installs old DLL overwriting the Windows ones.

Tooks ages to import the Reg File :)

Trying to load the app, tookes again ages (never seen that before on an app).
Strange first I only imported the Reg, and restarted the EMU.
Then i got always an Error Message like this
"Security device is timed out". Tried different dates in past but still that error message.
Did then again another reboot, and now it load faster and without error message. And for the first minutes it seems to work fine.
So its very important to do another reboot after the Reg Import.



02-20-2010, 08:05 AM
I suspect the reboot is for the Wilcom install, the emulator does not need it and would not make that difference.

I would be interested to hear if it continues to work. What OS BTW ?


02-20-2010, 08:17 AM
Sorry for disturbing you again, but can anybody tells me how to make devcon.exe work properly? Neither install.cmd nor install2.cmd doesn`t work on my Windows 7 64-bit. It says 'devcon' is not recognized as an internal or external command,
operable program or batch file.
If I put it to C:\Windows it says No device removed, devcon failed. Even if I check the box Run as administrator. UAC = off.
Google just says that there are 2 versions of devcon (32bit and 64) so what version is inside the package and how it can work on all windows versions. Sry if I ask n00bs questions I just sick and tired of using Wilcom on virtual windows xp and wanna install it directly to W7-64 bit.

02-20-2010, 08:22 AM

I'm on Windows 2003 Server 32Bit on the Moment (Modified to a Workstation).

And it wont crash after 30 Minutes. Played a little bit longer with it and no crash at all. Okay I'm not a proffesianal to use that app. And it maybe crashes if you use a specific funtions. But I really played around with lots of options and all went fine.

I think someone need to play with it for hours, using a lots of functions of the app to be sure.



02-20-2010, 08:27 AM
I'm on Windows 2003 Server 32Bit

As far as I know there`s no problem to use Wilcom on 32-bit system. Even on w7 it works. But I`ve never seen any solutions for 64-bit. I keep hoping for the best with this package but still no good news :mad:

02-20-2010, 08:28 AM
@git yes reboot is needed for software but that is only after software installation but err gives timeout msg.

can anybody here pls show me how to download from alt.binaries.crafts.pictures do I need to pay????

02-20-2010, 08:38 AM
do I need to pay????

I already paid $3 just to download from there. So there`s full package on my hard drive. I can re-upload it to any other file hosting system, I think there`s no need to upload full Wilcom, just emulator and hasp driver? Anyway please private message, I think it`s prohibited to give links right here.

PS. For the moment it doesn`t work on my W7-64. I`m waiting for some help.

02-20-2010, 08:40 AM

I think its quiete easy to answer. The inlcluded EMU is for 32BIT OS only. There is no 64BIT EMU inside. Thats why it wont work in Windows 7 64Bit. How could the same EMU work for 32Bit and 64Bit at the same time ????
Think about that yourself...

Btw, is this Wilcom Version 64 Bit approved, I mean also with a real Dongle ???

EDIT: Good news for the 64Bit Fans here...

You dont need to use the included EMU. Its only the V1.8.0.2 Version. You can use the widely available V1.8.0.3 Version. It works fine with that too. Since there is a 64Bit Version available for that Version, you could use then Wilcom on a 64 Bit OS. But you should read the guides to make the Mulikey EMU work on 64 Bit (I mean those Driver issues. Search for "Disable PatchGuard & Driver Signing")



02-20-2010, 09:00 AM
How could the same EMU work for 32Bit and 64Bit at the same time ????

Yeah, that`s the same question from my previous comment. But why sgraphixs has started this thread and lay special emphasis on 64-bit system. He doensn`t ask for money like others do. The only conclusion is to wait for sgraphixs here.

02-20-2010, 02:22 PM
Yogi - no, it is Usenet, it is free. Do you really not know it? It is responsible for 30% of internet traffic.


02-20-2010, 04:22 PM
So OK, there are two news, one is good, another`s bad :)
I managed to start wilcom on windows 7 64-bit. Here`s the screenshot:
http://img682.imageshack.us/img682/3456/wilcom.th.jpg (http://img682.imageshack.us/i/wilcom.jpg/)
It worked smoothly as long as I used it. I made a lot of changes to my OS, downloaded different files, tried a lot of different things. I`m not PRO, I even didn`t know about usenet ;) that`s why sometimes i didn`t know what exactly I did.
Here are my steps:
1. I install the HASP driver v5.22 in HASP4_driver directory due to instructions from the downloaded package.
2. install Wilcom ES-2006
3. install SP4 Revision 2
4. merge 57FD245C.reg with the registry, just double click on the file and it will ask if you want to add, click yes. (due to instructions from the downloaded package)
5. Here comes Lomex and help me. I downloaded Multikeyemu-V0.18.0.3. Use folder MultiKey64 from the package. Don`t install it now.
6. Now I downloaded Driver Signature Enforcement Overrider 1.3b which allows you to install and load unsigned drivers dynamically on your Windows 7. You should start it, Enable Test Mode, then Sign a system file and insert the name and full path to your MultiKey.sys from the folder MultiKey64 (see step 5). To check if the file signed now, right click on MultiKey.sys, Properties and the second tab -- there should be Digital signatures.
7. Now go to MultiKey64 folder and run install.cmd.
That`s all folks!
What about rebooting... I rebooted my PC all day long and I cant remember which steps required rebooting. Just reboot when needed.
What about one bad news. Bad news is that i was unable to complete 7 step. It said that "driver was successfully installed" but when I went to Device manager -> System Devices there was yellow exclamation mark -- Windows cannot verify the digital signature (Code 52). It always happened -- before Driver Signature Enforcement Overrider 1.3b and after that. I tried to use ReadyDriverPlus (to disable driver signature enforcement) but because of my Windows 7 Loader eXtreme that was wrong step. So to disable driver signature enforcement I just press F8 and choose "disable driver signature enforcement". After that yellow exclamation mark disappeared. MultiKey64 worked properly and some drivers (muitikey, alladin etc) were updated automatically from the Internet. Wilcom started and worked properly.
So sorry for long story. I need it to settle my mind :) The only problem with Wilcom is driver signature. As far as I understand there`s no possibility to disable this "feature". I hoped that Driver Signature Enforcement Overrider 1.3b solve this issue but I spent a lot of time and no luck. Can anybody help me with it? Maybe there`s multikey 64 with signed MultiKey.sys? Or maybe some other way to install multikey properly on windows 7-64?

02-21-2010, 12:02 AM
Default take what I posted in previous page, Wilcom does not say their product work on Win 7 x64, just x86 only!

02-21-2010, 05:06 AM
Wilcom does not say their product work on Win 7 x64, just x86 only!

asus, have you read what they said? Read your own quotation «ES 2006 (with Service Pack 4 Revision 2) and above will run on 64-bit operating systems such as Windows XP x64 and Windows Vista 64-bit as these operating systems can still run 32-bit applications natively.»
So what do you mean?

02-21-2010, 09:15 AM
Yes, I know what I read at Wilcom and posted here, but they do not point to Win 7 x64 - Take care this issue.

02-21-2010, 02:56 PM
Can't get this downloaded from the newsgroups. Anyway to post it anywhere else?


02-21-2010, 04:23 PM
So finally I made Wilcom to run on Windows 7 64 bit. I`ve solved all the issues with it and now I`m testing Wilcom. For some hours it works smoothly. Wilcom Design Workflow also works properly.

02-23-2010, 04:11 AM
Yeah! As LITMANEN said!

Here is the proof..
http://img246.imageshack.us/img246/200/wilcomes2006sp4r2.th.png (http://img246.imageshack.us/i/wilcomes2006sp4r2.png/)

Best regards, X

02-24-2010, 01:51 PM
hello Litmanen
I also managed to install in win 64 bits but the program works rather slow and fails to run the design workflow q my question to you was whether same thing happens

02-24-2010, 02:20 PM
frolito, look at my screenshot, as you can see Design Workflow starts and works properly. Wilcom also works properly. The only slow thing is starting. But I think it starts even faster now then it started at my Windows XP 32bit.

What xone says?

02-24-2010, 03:39 PM
Starting of application is very slow (I think it's because DTable is very long and there is many records to check), after that is working nice for me. I'll make some projects using it so I'll be able to say more.

02-24-2010, 04:17 PM
Tomorrow I`ll compare Wilcom starting time on Windows 7-64 with Windows XP 32bit. It looks to me like on Windows 7-64 quicker.

02-24-2010, 05:32 PM
q I apologize but I explain it wrong to start late as usual wilcon say q loq slows is when it starts to scan as you get behind the pointer q nodes do not move at normal speed wing.

but if you are going to try trabajndo normally installed everything from scratch again anyway thanks for answering any further comment as I do after installing and who knows if I do run workflow design

02-24-2010, 05:45 PM
frolitoz, sorry i can`t understand you. I repeat it again -- I can`t see any difference between wilcom on W7 and wilcom on XP. If I manage to understand you I`ll check what you are talking about. Or maybe xone`ll help you.

02-25-2010, 12:28 AM
Can any one post these files on Demonoid or some where else please?


work for life
02-25-2010, 04:28 AM
hi we all is talk about wilcom sp4 crack ,this cracker crack the wilcom sp4 with many difrent crack version ,and cheet money with update the crack off the version

02-25-2010, 04:30 AM
@git trust me I don't know anything about it how to download from usenet
I tried googling but still could not help me
as far as I know we can access them using google groups but could not see wilcom downloads

02-25-2010, 11:39 AM
Some more information than can be usefull for somebody:
At home I used (as i posted here on page 3) multikey 18.0.3. But when I installed Wilcom at work I decided to use 18.1.0. I thought that it was newer version and maybe it would work quicker or something... :) I installed everything and Wilcom didn`t start, no errors, just disappeared. OK, I had to uninstall 18.1.0, restarted, 18.0.3 was installed and Wilcom then started but there was an error: security device has timed out. I did everything like I had done it at home! (yes I added REG file twice, before installed 18.0.3 i had added it again). So the only chance left. When I install multikey there is always info message from Windows -- Updating your multikey from windows updating center and it downloads something from somewhere :) I remember that sgraphixs who uploaded the package to Usenet had wrote in his instructions "turn off Internet and make sure you don`t update drivers". That`s why I reinstalled 18.0.3 again and when it told me "updating your multikey bla bla bla" I quickly pressed SKIP. After that I double clicked Wilcom and my god -- it started successfully, no errors... So strange situation because I didn`t press SKIP at home PC and it also updated something. I even don`t know what windows can update about Multikey :)
PS. I hope my english is ok and everything is clear :-)

[Please do not reply to yourself. If yopu have something to add to your message, use the Edit button.]

So I`ve compared how long does it take for Wilcom ES Designer to start. From double click to working area appear.
Wilcom 2006 SP2 on Windows XP = 1 min 33 sec
Wilcom 2006 SP2 on guest system Windows XP on host system Windows 7 64 bit (vmware) = 1 min 10 sec. It`s a little bit quicker but it`s another much more powerful PC.
Wilcom 2006 SP4r2 on Windows 7 64 bit = 1:10.
And finally if I double click Design Workflow 2006 it takes 2:20 for BOTH programs to appear on W7-64bit.

[Are you completely stupid?. Let me repeat it so you can read it again :- Please do not reply to yourself. If you have something to add to your message, use the Edit button.]

Dear Git, I specially wrote 2 comments because they don`t have any relations to each other. The first was about solving the problem and another was just for fun. It seemed to me that it would be better readable if I separate them. But now it looks OK with your red text :-) cheers

02-25-2010, 04:51 PM
@ work for life,,,,, we are not ALLL stupid :mad: be specific if you want to insult yourself no one will deny you , but leave any one else alone
i tested es2006 SP4 using vmware and win 7 32bit , start time were about 30 sec only that were very fast , in win xp it takes about 1:30 min....regards

work for life
03-01-2010, 10:42 AM
i have make the version run in winxp just 30 sec and win7 32 and 64 bit 45 sec without antivirus

03-01-2010, 10:59 AM
[LAST WARNING : please do not quote whole messages. We can already see the original message]

How do people need your job?!

miss nobody
03-03-2010, 05:46 AM
Hi all ,
i am try to install wilcom2006 on my windows 7 but it dos not work..i saw in this tread someone talk about the Multikeyemu vo 18.03 and driver signature but can't find it on the net
Can someone please share this so i can try to install a working wilcom on my pc

Miss nobody

03-03-2010, 06:03 AM
miss are you using win 7 32bit or 64bit?

miss nobody
03-03-2010, 07:04 AM
Hi xone,
For now i use 32 bit but i want to buy a new pc with 64 bit
before i buy a new pc.. i want to know if i can get wilcom to work :D

03-03-2010, 07:13 AM
for 32bit windows it should work without problems, for 64bit windows use Driver Signature Enforcement Overrider 1.3b (http://www.anonym.to/?http://www.ngohq.com/home.php?page=dseo) to sign MultiKey
Using that tool you need change to test mode, when you are in test mode you can sign driver using DSEO and install it into system. You need to be in test mode if you want using signed this way driver.
Good luck :)

PS. It's working for me on 64bit Win 7 :)

miss nobody
03-03-2010, 07:39 AM
Thank you very much for your help.. i'm gonna try it out ;)

I have another question :D
If you have wilcom on your pc can you tell me please if it's reads eps file's ...i have wilcom2006 on winxp and i get an error when loading a eps file

03-03-2010, 08:06 AM
I've got the same error.. Maybe it's bug in SP4

miss nobody
03-03-2010, 08:56 AM
Thanks for the info ......wilcom is working now on my win 7 :)

03-03-2010, 04:36 PM
Hi all
I tried to use Driver Signature Enforcement Overrider 1.3b on Windows 7 64 Bit to let Multikey 64 work with no luck.
I am able to install the driver with no complain but under Control Panel I see a yellow mark with an error 52 coming from bad sgnature.
Can anybody help me?
thanks and Regards

03-03-2010, 04:41 PM
anyone else have the latest version of Wilcom Embroidery Studio with HASP SRM dongle?

03-03-2010, 08:48 PM
[You know the rules - stop quoting!]

I have it.
edit: sorry Git for my mistake.

03-04-2010, 02:15 AM
bolota, no.. you don't have it.. You have Wilcom ES 2006 SP4r2. Tyrus is asking about latest version of Wilcom Embroidery Studio e1.5.

03-04-2010, 08:59 AM
your version use hasp hl
i ask about new version with hasp srm (not hl)

03-05-2010, 05:22 PM
How to download ? i have accout giganews. but can't download and find wilcom es2006
plz help me. thx

03-05-2010, 08:26 PM
Hi guys,

its seems that there is another Reg File out for Wilcom 2006 SP4.
This one is even bigger (6 861 146 Bytes) and it includes lots more Dtables than the one in the first post. Its from a spanish guy, who made also full translation of the needed DLL files to spanish.

Dozens of users reported thats its working. I didnt tested if its works better than the one posted here (already deleted Wilcom on my system)

For experinced users of the Wilcom app, who wants to test this new reg file, could PM me.

I have a link for the Reg and Spanish Patch files only (with detailed install guide in spanish ;) )



03-10-2010, 12:36 AM
you got a link to the file?

03-10-2010, 02:01 AM
Spanish REG file is working too and it's even better that this one.. This one gives device time error after some time.

03-10-2010, 03:01 AM
there was one that was wrokign but after a few weeks will have a save pirated message.

That was the spanish one.

The best one is the sp2 one. however it only works in vista and xp. can't get it to work on win 7.

03-11-2010, 03:51 PM
Embroidery Studio - Does this software have a crack as I cant seem to find one out there?

03-12-2010, 01:35 AM
is wilcom ES & Embroidery studio both are different softwares
I have checked with wilcom site but cannot see wilcom ES

work for life
03-12-2010, 01:56 AM
yes if difrent tootaly from 2006 the new embroidery studio is version 2010 and have 3 difrent level protect with hasp srm +srm license from sentinel

03-26-2010, 08:38 PM
i am new at this could someone pass me a link where this registro.reg for Wilcom the 64-bit but the hasp or sentinel. thanks bye.

03-26-2010, 08:54 PM
I'm so new to this. I've seen the Wilcom 2006 on one of torrent site but I can't seem to find the one listed on this thread. Sorry but I know nothing about the usenet thingy. Does it cost to join?
Could anyone just listed on the torrent site?


03-28-2010, 01:24 PM
astrogirl, if you need wilcom for windows xp 32bit you can easily find it on the internet. Look for wilcom sp2. If you need it for Vista or 7 32bit -- you can also find it, look for wilcom sp4. And if you need it for 64bit then you should read this topic.

BEFORE joining usenet read the whole topic closely. You don`t need usenet because topic starter upload there the crack for 32-bit system only. If you need it you can get it much easier using Google. I downloaded the package from usenet so I know what`s inside.

03-29-2010, 11:53 AM
Can one install decostudio after installing V9 sp4 or will it kill it?

04-07-2010, 12:09 PM
can anyone share the link of 57FD245C.reg file?

04-12-2010, 08:19 AM
I tried several times and could not install on sevenX64
Can anyone share the installation files with a practical guide?:)

04-12-2010, 04:46 PM
I posted the complete instruction on page 3. What`s wrong? I know at least 4 persons who achieved the success, so check your steps or tell us where the problem is.

04-13-2010, 03:00 PM
hi Litmanem
may be that my files are not correct.
you could provide me this file that you used? :)

04-14-2010, 04:23 PM
Which file? All the files are available on the internet. Except .reg file maybe.

04-15-2010, 07:36 AM
Exactly, I do not have .reg:rolleyes:

04-15-2010, 02:27 PM
reg file (http://www.sendspace.com/file/6bsxaa) this comment is too short, omg

04-15-2010, 05:16 PM
Thanks Litmanem!:)
I will test the installation...

04-16-2010, 02:25 PM
I'll try it too! thanks

04-20-2010, 04:22 AM
Useful link (http://www.lobosolitario.com/foro/bordados-aplicaciones/wilcom-embroidery-studio-full-(solo-setup)/) for those who are interested in Wilcom. Now Wilcom Embroidery Studio available, but there`s no emu.

04-23-2010, 08:25 AM
This thread no longer has any reverse engineering content or interest, so I'm closing it.