Reverse Engineering RET Homepage RET Members Reverse Engineering Projects Reverse Engineering Papers Reversing Challenges Reverser Tools RET Re-Search Engine Reverse Engineering Forum Reverse Engineering Links

Go Back   Reverse Engineering Team Board > Reverse Engineering Board > Reverse Code Engineering
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 04-26-2010, 09:23 AM
calvin calvin is offline
Senior Member
 
Join Date: Feb 2010
Posts: 50
Default How to Inc. trial time of this Sentinel Dongle?

Hi,

I have a sentinel dongle. It is trial dongle valid for 78 more days. I have been able to dump the dongle with edgepro11 and i have a working .dng.

Now when i try to dump the dongle with PVA dumper and make a Mkey reg, the software does not detect the dongle. I tried to make a vusb reg, the software detects the dongle but gives and error.(i think the error is because the software cannot write into the registry)

I want to increase the trial period. The start and end dates are in Cell 52 and 53. Can someone help me in doing it?

The error shown by the software when using Vusb reg is also attached.
Attached Images
File Type: jpg Lic error.JPG (52.0 KB, 127 views)
Attached Files
File Type: zip AA2D0000.zip (562 Bytes, 66 views)
File Type: zip spro_RNBO_SPN_DRIVER_aa2d_0.zip (40.5 KB, 63 views)
Reply With Quote
  #2  
Old 04-26-2010, 09:34 AM
Git Git is offline
Super Moderator
 
Join Date: Oct 2007
Location: Torino
Posts: 1,797
Default

Try to make the firt line of CellType like this :

"CellType"=hex:\
01,01,03,03,03,01,03,01,\

Git
Reply With Quote
  #3  
Old 04-26-2010, 09:36 AM
bassem_16 bassem_16 is offline
Senior Member
 
Join Date: Feb 2010
Posts: 66
Default

Another challenge calvin

Can you post the software link as well? To be able to try as well

@ Calvin,Git is absolutely right if you were using MK18.2.3 or .4 otherwise use MKey 18.0.3
Reply With Quote
  #4  
Old 04-26-2010, 09:39 AM
calvin calvin is offline
Senior Member
 
Join Date: Feb 2010
Posts: 50
Default

@Git,

I have tried but it doesn't help.

If i use sproeval, findfirstunit(aa2d) gives error (return code 110)

@bassem_16

the software is at

Quote:
-----
regards,

Last edited by calvin : 04-27-2010 at 07:11 AM. Reason: link updated
Reply With Quote
  #5  
Old 04-26-2010, 10:15 AM
Git Git is offline
Super Moderator
 
Join Date: Oct 2007
Location: Torino
Posts: 1,797
Default

110 SP_SERVER_VERSION_NOT_SUPPORTED
"The Sentinel Protection Server from which you are trying to
obtain a license is outdated."

Git
Reply With Quote
  #6  
Old 04-26-2010, 11:13 AM
calvin calvin is offline
Senior Member
 
Join Date: Feb 2010
Posts: 50
Default

But if I make a Vusb reg the dongle is detected...
How to overcome the make the Vusb work with software if MK reg is not working ?
Reply With Quote
  #7  
Old 04-26-2010, 11:50 AM
Git Git is offline
Super Moderator
 
Join Date: Oct 2007
Location: Torino
Posts: 1,797
Default

First, forget the App, why does SproEval not work?. I know for a fact that it does not detect MK. Make sure you have sentinel drivers V7.5.0 because they definitely do not detect the emulator. Now, SproEval should work on emulator (real dongle unplugged). Do not go any further until SproEval works. If SproEval does not work you do NOT have a working emulator IME.

If you want to avoid detection, rename the multikey.sys, but it is not as easy as it first sounds. You have to uninstall multikey. You have to rename all mentions of the filename in multikey.cmd, multikey.bat and multikey.inf files. You then have to install your new emulator. My suggestion would be to make a copy of the MK Inf directory, and do all change in there, then install from there.

Git
Reply With Quote
  #8  
Old 04-26-2010, 01:08 PM
calvin calvin is offline
Senior Member
 
Join Date: Feb 2010
Posts: 50
Default

Thanks Git,

As suggested, I have uninstalled MK and sentinel drivers. Installed sentinel drivers 7.5.0. Installed MK 18.2.4, imported the reg and restarted MK.

Finally MK is working and software can detect the dongle atleast.

But the software is again giving same error.

Any idea what is causing the problem. The software is working fine with sentemul 2007.

One observation - if i change the system time to any time earlier 26-4-2010 17:58 (the time at which i made the Dump,shown as last run time), the software runs smoothly...with sentemul the last run time and current time is updated automatically..the same is not happening with MK.

regards,
Attached Images
File Type: jpg Lic error3.JPG (52.6 KB, 69 views)

Last edited by calvin : 04-26-2010 at 01:55 PM.
Reply With Quote
  #9  
Old 04-26-2010, 02:08 PM
Git Git is offline
Super Moderator
 
Join Date: Oct 2007
Location: Torino
Posts: 1,797
Default

We discussed making MK write to the registry in the last thread, I don't see any need to repeat it all again.

Git
Reply With Quote
  #10  
Old 04-27-2010, 12:21 AM
calvin calvin is offline
Senior Member
 
Join Date: Feb 2010
Posts: 50
Default

Thanks Git,

I don't remember the discussion, I will have to search I guess
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.