Reverse Engineering RET Homepage RET Members Reverse Engineering Projects Reverse Engineering Papers Reversing Challenges Reverser Tools RET Re-Search Engine Reverse Engineering Forum Reverse Engineering Links

Go Back   Reverse Engineering Team Board > Reverse Engineering Board > Reverse Code Engineering
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #161  
Old 04-24-2008, 06:42 AM
kalhua kalhua is offline
Junior Member
 
Join Date: Apr 2008
Posts: 3
Default

Thanks for your reply.... brings up some more question:

1. What type of protection is it so I can do some more reading?

2. Can it be emulated? If yes, which is the best choice for an emulator?

3. Are you able to tell if I actually got a good dump and have all info to emu by what I posted?


Thanks
Reply With Quote
  #162  
Old 04-24-2008, 12:21 PM
y8y8y8y y8y8y8y is offline
Senior Member
 
Join Date: Sep 2007
Posts: 210
Default

@kalhua
In dump folder after dump do you even see the hhl_mem.dmp file?
Reply With Quote
  #163  
Old 04-24-2008, 03:19 PM
kalhua kalhua is offline
Junior Member
 
Join Date: Apr 2008
Posts: 3
Default

Quote:
Originally Posted by y8y8y8y View Post
@kalhua
In dump folder after dump do you even see the hhl_mem.dmp file?
I did get that file with the dump however when I tried to use it an error came up saying it was the wrong size. There were no errors with h5dmp.exe when it created the file.

Thanks
Reply With Quote
  #164  
Old 04-25-2008, 12:05 PM
eng-ars eng-ars is offline
Member
 
Join Date: Feb 2008
Location: Mexico
Posts: 29
Send a message via MSN to eng-ars
Default Strange Performance.... Hasp HL Max

Hi... I have been trying to emulate the HASP HL Max.... But is dificult.... In a session with vsub emulator, HaspLoger and my soft... The error 1031 Unknown Envelope is displayed... And reviewing the hasploger monitor... Then I saw that the soft send a Question diferent everytime that I try to run... Ok this isn't new... The Random performance is know... But the strange is the Response that vusb emulator send... It isn't similar to any response that add in .REG file... Always send the same response... And trying to understand why this response... Opened the HaspEditor_Hl by sataron, wrote the pass of dongle emulated and then pressed the "Make E\D Pairs" and the app generated 6 files in .txt with 258 pairs each, called OutLog16_Decode.txt, OutLog16_Encode.txt, OutLog32_Decode.txt, OutLog16_Encode.txt, OutLog48_Decode.txt, OutLog48_Encode.txt.... But all files have the same respond, obviusly, with diferent long... 16, 32 or 48 .... and this is the response that de vsub emul give to the soft for each question that do it.... I believe that some is missed in the emulation procces... Or the vusb emul is not prepared for this dongle type... Some have any idea ?

P.S. Some have ToroEmulatorUtility.exe... and tools to generate the .HASP file ?... Please... Help me with Hasp HL Max... It is win the game...

eng-ars
Reply With Quote
  #165  
Old 04-25-2008, 12:13 PM
y8y8y8y y8y8y8y is offline
Senior Member
 
Join Date: Sep 2007
Posts: 210
Default

Try to check in registry do you see the Q/A tables you prepared?
Reply With Quote
  #166  
Old 05-07-2008, 08:10 AM
Athar Husain Athar Husain is offline
Member
 
Join Date: Mar 2008
Posts: 10
Default

Hi All,

Could anyone here please tell me why my h5dmp.exe not executing???? I am trying to dump my dongle with this software but when i double click the h5dmp.exe, a small black screen is visible for a very quick second, and then vanishes. Could anyone please guide me what wrong am i doing??? Any help will be highly appreciated from the core of my heart.
Reply With Quote
  #167  
Old 05-07-2008, 08:15 AM
benito benito is offline
Senior Member
 
Join Date: Jul 2007
Posts: 685
Default

Quote:
Originally Posted by Athar Husain View Post
Hi All,

Could anyone here please tell me why my h5dmp.exe not executing???? I am trying to dump my dongle with this software but when i double click the h5dmp.exe, a small black screen is visible for a very quick second, and then vanishes. Could anyone please guide me what wrong am i doing??? Any help will be highly appreciated from the core of my heart.
Why do you make duplicate posts???
Reply With Quote
  #168  
Old 05-07-2008, 08:17 AM
souze_villy souze_villy is offline
Senior Member
 
Join Date: Oct 2007
Posts: 220
Send a message via MSN to souze_villy Send a message via Yahoo to souze_villy
Default

Quote:
Originally Posted by Athar Husain View Post
Hi All,

Could anyone here please tell me why my h5dmp.exe not executing???? I am trying to dump my dongle with this software but when i double click the h5dmp.exe, a small black screen is visible for a very quick second, and then vanishes. Could anyone please guide me what wrong am i doing??? Any help will be highly appreciated from the core of my heart.
open then notpad and wrote the here this instructions,
@Echo Off
h5dmp.exe 0xXXXX 0xXXXX
pause
and save as file name XXXX.bat
and then try.

0xXXXX 0xXXXX mean what u have donge ID 12345678, then same wroe, 0x1234 0x5678.
Reply With Quote
  #169  
Old 05-07-2008, 08:30 AM
Athar Husain Athar Husain is offline
Member
 
Join Date: Mar 2008
Posts: 10
Default

Thanks a lot souze --- i m going to try it right now.
Reply With Quote
  #170  
Old 05-07-2008, 07:00 PM
justine justine is offline
Senior Member
 
Join Date: Dec 2007
Location: Serbia,Belgrade
Posts: 82
Send a message via ICQ to justine Send a message via MSN to justine Send a message via Yahoo to justine Send a message via Skype™ to justine
Default

just use "make dump.bat" as i already desrcibed

you can execute h5dmp.exe directly if you want but then you need to run it from "cmd.exe" (start>>run>>>cmd) and you need to specify pass1 pass2 manualy

better use "make dump.bat"
passwords that you need are already specified inside package that i sent you
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump





Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.